Вопрос по информатике:
Написать программу, которая определит все четырёхзначные числа являющиеся симметричными, т.е abcd a+b=c+d и вывести на экран через пробелы, посчитав при этом их количество
- 16.10.2016 00:02
- Информатика
- remove_red_eye 6744
- thumb_up 10
Ответы и объяснения 1
Program n;
uses crt;
var i,a,b,c,d,k:integer;
begin
k:=0;
for i:=1000 to 9999 do begin
a:=i div 1000;
b:=i div 100 mod 10;
c:=i div 10 mod 10;
d:=i mod 10;
if a+b=c+d then begin
write(i,' '); k:=k+1; end;
end; writeln;
writeln(k,' шт'');
end.
- 17.10.2016 12:20
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.