Вопрос по информатике:
Дана строка, состоящая из 50 символов. Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог ‘ea’.
- 21.12.2017 18:45
- Информатика
- remove_red_eye 1707
- thumb_up 8
Ответы и объяснения 1
Var s:string;k:integer;
procedure SubInc(var s:string;var k:integer);
begin;
while pos('ea',s)0 do
begin;
delete(s,pos('ea',s),2);
inc(k);
end;
end;
begin;
readln(s);
if length(s)10 then exit;
SubInc(s,k);
writeln(k);
end.
- 22.12.2017 20:31
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.