Вопрос по информатике:
Составьте программу, которая заполняет массив a [1...10] случайными целыми числами в диапазоне от 1 до 20 и находит минимальный элемент массива и его индекс
- 07.04.2017 13:21
- Информатика
- remove_red_eye 12689
- thumb_up 32
Ответы и объяснения 1
Var
a:array[1..100] of integer;
min, minz, i:integer;
Begin
randomize;
minz:=30;
for i:=1 to 10 do a[i]:=random(20)+1;
for i:=1 to 10 do
if minz>a[i] then begin minz:=a[i]; min:=i; End;
for i:=1 to 10 do Write(a[i],' ');
Writeln();
Writeln(minz,' ',min);
End.
- 08.04.2017 09:48
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.