Вопрос по информатике:
Составить программу, в которой получить как можно больше слов, образованных из слова информатика. Вывести на экран длину исходного слова. (Программа на языке Паскаль, использовать команды: length, copy, delete, insert, concat.)
Желательно сделать до завтрешнего дня, информатика завтра будет. Заранее спасибо)
- 12.09.2018 03:58
- Информатика
- remove_red_eye 12895
- thumb_up 9
Ответы и объяснения 1
Из слова "информатика" так много всего можно сделать!
Вот небольшая часть:
var s,s1:string;
begin
s:='информатика';
//1 способ
s1:=copy(s,3,5);
writeln(s1,'-',length(s1));
//2 способ
s1:=s;delete(s1,8,4);
delete(s1,1,2);
writeln(s1,'-',length(s1));
//3
s1:=s;delete(s1,1,5);
delete(s1,3,2);
insert(copy(s,5,1),s1,3);
writeln(s1,'-',length(s1));
//4
s1:=copy(s,5,1)+copy(s,4,1)+copy(s,6,2)+copy(s,2,1)+copy(s,8,3);
writeln(s1,'-',length(s1));
//5
s1:=concat(copy(s,3,3),copy(s,8,1));
writeln(s1,'-',length(s1));
end.
- 13.09.2018 07:28
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.