Вопрос по информатике:
Даны две квадратные матрицы А и В размером 3х3. Требуется найти С=А х В.
Составить программу нахождения числа строк матрицы А(N,N), сумма элементов у которых отрицательна.
pascal abc
- 03.09.2018 17:46
- Информатика
- remove_red_eye 14852
- thumb_up 28
Ответы и объяснения 1
1)var a:array[1..3,1..3] of integer;
b:array[1..3,1..3] of integer;
c:array[1..3,1..3] of integer;
i,j:integer;
begin;
writeln('A array:');
for i:=1 to 3 do
begin;
writeln;
for j:=1 to 3 do
begin;
a[i,j]:=random(10)-10;
write(a[i,j]:4);
end;
end;
writeln;
writeln('B array:');
for i:=1 to 3 do
begin;
writeln;
for j:=1 to 3 do
begin;
b[i,j]:=random(-10,10);
write(b[i,j]:4);
end;
end;
writeln;
writeln('C array:');
for i:=1 to 3 do
begin;
writeln;
for j:=1 to 3 do
begin;
c[i,j]:=a[i,j]*b[i,j];
write(c[i,j]:4);
end;
end;
end.
2)var a:array[1..1000,1..1000] of integer;
i,j,k,n,u:integer;
begin;
randomize;
readln(n);
writeln('A array:');
for i:=1 to n do begin;
writeln;
for j:=1 to n do
begin;
a[i,j]:=random(10)-10;
write(a[i,j]:4);
end;
end;
for i:=1 to n do begin;
for j:=1 to n do
u+=a[i,j];
if u<0 then inc(k);
u:=0;
end;
writeln;
write('Result:',k);
end.
- 04.09.2018 18:17
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.