Вопрос по информатике:
Помогите написать программу в Pascal. ПОЖАЛУЙСТА!!!
Переписать сведения о багаже из переменной Bagaj в переменную Bag. В переменной Bag сведения о багаже каждого пассажира представляются массивом из двух целых чисел - числа вещей и общего веса вещей, выраженного в граммах. Составить также программу обратного преобразования: переписи сведений о багаже из переменной Bag в переменную Bagaj.
- 07.06.2018 11:43
- Информатика
- remove_red_eye 2417
- thumb_up 37
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1073
var
Bag,Bagaj:array[1..2] of longint;
begin
Bagaj[1]:=5; Bagaj[2]:=43600;
{ перенос Bagaj -> Bag }
Bag[1]:=Bagaj[1]; Bag[2]:=Bagaj[2];
Writeln('Предметов- ',Bag[1],', общий вес ',Bag[2]);
Bag[1]:=4; Bag[2]:=24540;
{ перенос Bag -> Bagaj }
Bagaj[1]:=Bag[1]; Bagaj[2]:=Bag[2];
Writeln('Предметов- ',Bagaj[1],', общий вес ',Bagaj[2]);
end.
Тестовое решение:
Предметов- 5, общий вес 43600
Предметов- 4, общий вес 24540
- 08.06.2018 01:14
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.