Вопрос по информатике:
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ниже предоставлен рекомендуемый вид экрана во время работы с программой
Введите сумму покупки 1200
Сумма покупки с учётом скидки 1080
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 17.12.2016 23:44
- Информатика
- remove_red_eye 18148
- thumb_up 41
Ответы и объяснения 1
Точно не уверен но вроде так:
var
s:real;
begin
writeln ('Введите сумму покупки: ');
readln(s);
if s>1000 then
begin
writeln('Сумма покупки с учётом скидки: ',s*0.9:0:2,' руб.');
end
else
writeln('Сумма покупки: ',s:0:2,' руб.');
end.
- 18.12.2016 12:59
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.