Вопрос по информатике:
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое из исходного перестановкой его первой и последней цифр.
- 11.02.2018 04:46
- Информатика
- remove_red_eye 10066
- thumb_up 41
Ответы и объяснения 1
Var a,bug:integer;
s,s1,s2:string;
begin;
readln(a);
str(a,s); //переводим число в строку
s1:=s[1]; //запоминаем 1 символ
s2:=s[length(s)]; //запоминаем крайний символ
delete(s,1,1); //удаляем 1 символ
delete(s,length(s),1); //удаляем крайний символ
insert(s2,s,1); //ставим сохранённый крайний символ на первое место
insert(s1,s,length(s)); //ставим сохранённый первый символ в конец
val(s,a,bug); //делаем строку числом, не забыв о возможности багов
writeln(a);
end.
- 12.02.2018 14:27
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.