Вопрос по информатике:
Составить программу,решающую следующую задачу: дано трехзначное число. Вывести число, полученное при перестановке крайних цифр исходно числа.
Пожалуйста, помогите!!!
- 05.11.2017 20:50
- Информатика
- remove_red_eye 14840
- thumb_up 20
Ответы и объяснения 1
Паскаль:
program chislo;
var N,c1,c2,c3:integer;
begin
readln(N);
c1:=N div 100; {цифра разряда сотен}
c2:=(N div 10) mod 10;
c3:=N mod 10;{цифра разряда единиц}
writeln(c3*100+c2*10+c1);
end.
- 06.11.2017 00:08
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.