Вопрос по информатике:
Напишите программу для паскаль! Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево упорядоченной по возрастанию.
- 25.04.2018 04:34
- Информатика
- remove_red_eye 17016
- thumb_up 41
Ответы и объяснения 1
Var n,k:integer; b:boolean;
begin
write('n='); readln(n);
b:=true;k:=0;
while n0 do
begin
b:=b and (n mod 10>k);
k:=n mod 10;
n:=n div 10;
end;
if b then writeln('Цифры числа упорядочены')
else writeln('Цифры числа не упорядочены');
end.
- 26.04.2018 15:23
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.