Вопрос по информатике:
Работа в Паскаль! Пожалуйста, хелп:3
1. Составьте программу, которая находит сумму N чисел, введенных с клавиатуры.
2.Составьте программу, которая вычисляет произведение чисел от 1 до N. Значение N вводится с клавиатуры.
- 23.12.2017 08:52
- Информатика
- remove_red_eye 7646
- thumb_up 7
Ответы и объяснения 1
1. var s,x,n,i:longint;
begin
s:=0;
readln(n);
for i:=1 to n do begin
read(x);
s:=s+x;
end;
writeln(s);
end.
2. var i, n, p:longint;
begin
readln(n);
p:=1;
for i:=1 to n do
p:=p*i;
writeln(p);
end.
- 24.12.2017 03:28
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.