Вопрос по информатике:
Алгоритм вычисления функции Fn,где n-натуральное число,задан следующими соотношениями:
F1=1;F2=1;
Fn=Fn-2+Fn-1 при n<2
Чему равно F5?
- 24.02.2017 12:44
- Информатика
- remove_red_eye 639
- thumb_up 42
Ответы и объяснения 1
Ошибка в условии!
Fn=Fn-2+Fn-1 при n>2!
Программа для вычисления Fn:
var f1,f2,fn,i:integer;
begin
f1:=1;f2:=1;
for i:=3 to 5 do
begin
fn:=f1+f2; f1:=f2; f2:=fn;
end;
writeln('fn=',fn);
end.
- 25.02.2017 04:27
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.