Вопрос по информатике:
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.
- 15.06.2017 12:45
- Информатика
- remove_red_eye 15220
- thumb_up 43
Ответы и объяснения 1
Program Main; Var a:array[1..1000]of integer; i,n,k:integer; begin write('Введите количество элементов в массиве: '); readln(n); writeln('Введите массив: '); for i:=1 to n do read(a[i]); writeln; k:=0; for i:=1 to n-1 do if (a[i]=a[i+1]) then k:=k+1; if (k>0) then writeln('Есть ',k,' пар соседних элементов с одинаковым значением') else writeln ('Нет пар соседних элементов с одинаковым значением'); end.
- 16.06.2017 19:06
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.