Вопрос по информатике:
Помогите написать программу на Паскале
Дан массив.вставить число К перед и после элементов,которые заканчиваются на ту же цифру,что и К
- 22.08.2017 07:17
- Информатика
- remove_red_eye 17969
- thumb_up 50
Ответы и объяснения 1
Const n=10;
type mas=array[1..3*n] of integer;
procedure ins(var a:mas;k,nom:integer);
var i:integer;
begin
for i:=3*n downto nom+3 do a[i]:=a[i-2];
a[nom+1]:=a[nom]; a[nom]:=k; a[nom+2]:=k;
end;
var b : mas; k,i,j : integer;
begin
Randomize;
for i:=1 to n do begin
b[i]:=random(51);
write(b[i]:4);
end;
writeln;
write('K=');readln(k);
j:=1;
for i:=1 to n do
if (b[j] mod 10 = k mod 10) then
begin ins(b,k,j); j:=j+3 end
else j:=j+1;
for i:=1 to 3*n do write(b[i]:4);
writeln;
end.
- 23.08.2017 23:46
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.