Вопрос по информатике:
Дано три числа, записанный в отдельных строках. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a <= b <= c, затем программа выводит тройку a, b, c.
Входные данные:
Вводятся три числа, каждое записано в отдельной строке.
Выходные данные:
Выведите ответ на задачу.
program abc;
var a,b,c : longint ;
begin
read(a,b,c);
if (a>=b>=c)then
write (a,b,c)
else
if (a>=c>=b) then
write (a,c,b)
else
if (b>=a>=c) then
write (b,a,c)
else
if (b>=c>=a) then
write(b,c,a)
else
if (c>=a>=b) then
write(c,a,b)
else
write(c,b,a);
end.
почему пишет ошибку "Операция '>=' не применима к типам boolean и integer" ?
отдам 20 баллов, только подскажите главное)
- 19.08.2018 02:28
- Информатика
- remove_red_eye 4621
- thumb_up 18
Ответы и объяснения 1
Главная ошибка в том, что нельзя записывать условие (a>=b>=c)
Надо это условие записывать так:
(a>=b) and (b>=c)
- 20.08.2018 10:50
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.