Вопрос по информатике:
Составить программу вычисления количества трёхзначных чисел которые не кратны 5
С ПОМОЩЬЮ WHILE
- 09.09.2018 05:00
- Информатика
- remove_red_eye 1600
- thumb_up 30
Ответы и объяснения 2
Var i,k:integer;
begin;
i:=100;
while i1000 do
begin;
if i mod 50 then k:=k+1;
inc(i);
end;
writeln(k);
end.
- 01.01.1970 00:00
- thumb_up 26
Заметим, что всего имеется 900 трехзначных чисел - от 100 до 999.
Если посчитать, сколько среди них чисел, кратных пяти, то вычтя его из 900, получим искомый ответ.
Первое число, кратное 5, это 100. А все остальные получаются путем последовательного прибавления числа 5.
// PascalABC.Net 3.0, сборка 1064
var
i,n:integer;
begin
n:=0; i:=100;
while i<1000 do begin Inc(n); i:=i+5 end;
Writeln('Количество чисел равно ',900-n)
end.
Результат выполнения программы:
Количество чисел равно 720
- 01.01.1970 00:00
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.