Вопрос по информатике:
Написать программу нахождения суммы четных и нечетных элементов массива, заполненного случайным образом от -100 до 100
помогите пожалуйста!!!!!нужна программа в Pascal!!!!
- 05.11.2017 18:55
- Информатика
- remove_red_eye 6968
- thumb_up 15
Ответы и объяснения 1
Const n=10;
var a:array[1..n] of integer;
c,d,i: integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(201)-100;
Writeln('Заданные числа, с помощью рандома: ');
for i:=1 to n do
writeln(a[i],' ');
for i:=1 to n do
if a[i] mod 2=0 then c:=c+a[i] else d:=d+a[i];
Writeln('Сумма четных элементов: ',c);
Writeln('Сумма нечетных элементов: ',d);
end.
- 06.11.2017 07:12
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.