Вопрос по информатике:
Дайте текст программы паскаль
Кеша Канарейкин обдумывал важное стратегическое решение. Он планировал переместиться
из точки A в точку B, и дождь, который шёл уже несколько часов кряду, его крайне огорчал. Не
то чтобы Кеша не любил иной раз погулять под дождём, но то, что сейчас происходило за окном,
можно было охарактеризовать как сильный ливень. Так что Кеше хотелось как можно меньшее
время находиться на улице.
Кеша может пойти из A в B по одной из двух дорог. При этом одна дорога имеет длину d1 и на
ней встречаются небольшие лужи. Кеша может двигаться по этой дороге со скоростью v1.
Вторая дорога имеет длину d2, но на ней есть участок длины p2, который является одной большой
лужей. В этой луже лежат кирпичи, по которым всё же можно через неё перебраться. Так что
Кеша может двигаться по второй дороге со скоростью v2, но, когда идет через лужу, то двигается
со скоростью w.
Ваша задача — определить дорогу, идя по которой, Кеша затратит меньшее время.
Формат входных данных
В первой строке содержатся целые числа d1 и v1 (1 ⩽ d1 ⩽ 100, 1 ⩽ v1 ⩽ 100) — длина первой
дороги и скорость, с которой может двигаться по ней Кеша.
Во второй строке содержатся целые числа d2, p2, v2, w
(1 ⩽ d2 ⩽ 100, 1 ⩽ p2 ⩽ d2, 1 ⩽ w ⩽ v2 ⩽ 100) — длина второй дороги, длина участка с
большой лужей, скорость Кеши при движении по второй дороге, скорость Кеши при движении по
луже.
Формат выходных данных
Выведите число 1, если Кеше следует пойти по первой дороге, и число 2, если Кеше следует
пойти по второй дороге.
Если нет разницы, по какой дороге идти, выведите 0Кеша Канарейкин обдумывал важное стратегическое решение. Он планировал переместиться
из точки A в точку B, и дождь, который шёл уже несколько часов кряду, его крайне огорчал. Не
то чтобы Кеша не любил иной раз погулять под дождём, но то, что сейчас происходило за окном,
можно было охарактеризовать как сильный ливень. Так что Кеше хотелось как можно меньшее
время находиться на улице.
Кеша может пойти из A в B по одной из двух дорог. При этом одна дорога имеет длину d1 и на
ней встречаются небольшие лужи. Кеша может двигаться по этой дороге со скоростью v1.
Вторая дорога имеет длину d2, но на ней есть участок длины p2, который является одной большой
лужей. В этой луже лежат кирпичи, по которым всё же можно через неё перебраться. Так что
Кеша может двигаться по второй дороге со скоростью v2, но, когда идет через лужу, то двигается
со скоростью w.
Ваша задача — определить дорогу, идя по которой, Кеша затратит меньшее время.
Формат входных данных
В первой строке содержатся целые числа d1 и v1 (1 ⩽ d1 ⩽ 100, 1 ⩽ v1 ⩽ 100) — длина первой
дороги и скорость, с которой может двигаться по ней Кеша.
Во второй строке содержатся целые числа d2, p2, v2, w
(1 ⩽ d2 ⩽ 100, 1 ⩽ p2 ⩽ d2, 1 ⩽ w ⩽ v2 ⩽ 100) — длина второй дороги, длина участка с
большой лужей, скорость Кеши при движении по второй дороге, скорость Кеши при движении по
луже.
Формат выходных данных
Выведите число 1, если Кеше следует пойти по первой дороге, и число 2, если Кеше следует
пойти по второй дороге.
Если нет разницы, по какой дороге идти, выведите 0
- 02.11.2015 05:08
- Информатика
- remove_red_eye 15683
- thumb_up 10
Ответы и объяснения 1
Var
d1, v1: integer;
d2, p2, v2, w: integer;
t1, t2: real;
begin
readln(d1,v1);
readln(d2,p2,v2,w);
t1:= d1 / v1;
t2:= (d2 - p2) / v2 + (p2 / w);
if (t1 < t2) then
write('1')
else if (t2 < t1) then
write('2')
else
write('0');
end.
- 03.11.2015 14:18
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.