Вопрос по информатике:
Составить программу вычисления значения функции при любых Х
y ;= sin*(3.2+ (sqrt(1-x))/abs(5*x))
- 10.04.2018 00:49
- Информатика
- remove_red_eye 2322
- thumb_up 20
Ответы и объяснения 2
// PascalABC.Net 3.0, сборка 1052
var
x,y:real;
begin
Writeln('Введите значение x: '); Read(x);
if (x=0) or (x>1) then Writeln('Значение функции не определено')
else begin
y:=sin(3.2+sqrt(1-x)/abs(5*x));
Writeln('Значение функции равно ',y)
end
end.
Тестовое решение:
Введите значение x: 0.634
Значение функции равно -0.246679689801614
- 01.01.1970 00:00
- thumb_up 40
//sin* - это что-то новое, так что обойдёмся без умножения.
var x,y:real;
begin;
readln(x);
if (x=0) or (x>1) then
begin;
writeln('Ошибка');
exit;
end;
y:=sin(3.2+(sqrt(1-x))/abs(5*x));
writeln(y);
end.
- 01.01.1970 00:00
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.