Вопрос по информатике:
Массив из 10 элементов вводится с клавиатуры. Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).
- 26.10.2017 02:46
- Информатика
- remove_red_eye 19946
- thumb_up 24
Ответы и объяснения 1
Шо-то изи
int[] a = new int[10];
Scanner scn = new Scanner(System.in);
for (int i = 0; i < a.length; i++)
a[i] = scn.nextInt();
System.out.println("Input 2 number, to choose numbers from massive");
int b = scn.nextInt();
int c = scn.nextInt();
System.out.println((a[b] + a[c]) / 2);
Проверка:
$ javac Main.java
1 2 3 4 5 6 7 8 9 10
1 5
4
- 27.10.2017 01:00
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.