Вопрос по информатике:
Написать программу , которая заполняет элементами массив по правилу: а(I)= (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив , в котором заменены на противоположные знаки элементов исходного массива . I=1,2,3...10
- 14.02.2018 00:30
- Информатика
- remove_red_eye 15308
- thumb_up 7
Ответы и объяснения 1
Var a:array[1..10]of Integer;
i,k:Integer;
p:LongInt;
begin
p:=1;
k:=0;
Writeln('Сгенерированный массив:');
Randomize;
for i:=1 to 10 dobegina[i]:=Random(10)+1;if a[i] mod 2=1 then p:=p*a[i] else k:=k+1;
Write(a[i],' ');
end;
Writeln;
Writeln('Произведение нечетных:',p);
Writeln('Количество четных:',k);
Readln;
end.
- 14.02.2018 01:52
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.