Вопрос по информатике:
Написать программу для вычисления суммы элементов заданного числового массива
- 16.05.2018 04:27
- Информатика
- remove_red_eye 10745
- thumb_up 46
Ответы и объяснения 1
program massiv6;
02.uses crt;
03.const N=10;
04.type x=array [1..N] of integer;
05.var a:x;
06.i:integer;
07.s:integer;
08.begin
09.clrscr;
10.randomize;
11.for i:=1 to N do
12.begin
13.a[i]:=-100+random(201);
14.write (A[i]:5)
15.end;
16.writeln;
17.s:=0;
18.for i:=1 to N do
19.if a[i]>0 then
20.begin
21.s:=s+a[i]
22.end;
23.writeln (‘Сумма положительных элементов = ’,s:5);
24.readln
25.end.
- 17.05.2018 02:06
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.