Вопрос по информатике:
Написать программу для решения следующей задачи: в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента. Если все элементы последовательности неотрицательны, то вывести ноль.
program lab5_5;
const n=10;
type x=array[1..n] of integer;
var a:x;
i:integer;
k:integer;
begin
for i:=1 to n do
begin
a[i]:=-10+random (91);
write (A[i]:4)
end;
writeln;
k:=0;
for i:=n downto 1 do
if a[i]<0 then
begin
k:=I
end;
if k>0 then
writeln (‘Индекс отрицательного элемента=’,k:1)
else
writeln (‘В массиве нет отрицательных элементов’);
readln;
end.
как сделать эту программу без random чтоб работало в Pascal ABC?
- 26.09.2018 16:49
- Информатика
- remove_red_eye 9745
- thumb_up 32
Ответы и объяснения 1
Program lab5_5;
const n=10;
type x=array[1..n]
of integer;
var a:x;i,k:integer;
begin
for i:=1 to n do
begin
read(a[i]); {с вашего позволения я убрал "write (A[i]:4)" в остальном программа получает от пользователя 10 чисел и обрабатывает их}
end;
writeln;
k:=0;
for i:=n downto 1 do
if a[i]<0 then
begin
k:=I
end;
if k>0 then
writeln ('Индекс отрицательного элемента=',k:1)
else
writeln ('В массиве нет отрицательных элементов');
readln;
end.
- 27.09.2018 21:50
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.