Вопрос по информатике:
Помогите написать программу на паскале
Срочно
вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16..
- 03.05.2018 09:10
- Информатика
- remove_red_eye 14669
- thumb_up 14
Ответы и объяснения 1
Данная последовательность -- последовательность центральных многоугольных чисел. Вычисляется по формуле a(n) = n*(n+1)/2 + 1. Или a(1) = 1, a(n+1) = a(n) + n.
Var
a, i: integer;
Begin
a := 1;
for i := 1 to 10 do
begin
writeln('base=', a, 'square=', a*a, ' cube=', a*a*a);
inc(a, i);
end
End.
- 04.05.2018 16:22
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.