Вопрос по информатике:
Составить программу которая вводит х и у с клавиатуры вычисляет и выводит на экран значение z =9x^4- корень из x+|y| поделить на (y+7) в фарматном виде с двумя знаками после точки
- 25.07.2016 13:03
- Информатика
- remove_red_eye 16369
- thumb_up 44
Ответы и объяснения 1
Могу предложить на Паскале:
uses Crt;
var x, y, z: real;
begin
ClrScr;
Write ('x = '); ReadLn(x);
Write ('y = '); ReadLn(y);
if (y-7) and (x+abs(y)>=0)
then
begin
z:=9*sqr(sqr(x))-sqrt(x+abs(y))/(y+7);
WriteLn('z = ', z:4:2);
end
else Writeln('None!');
ReadLn;
end.
Здесь важно учесть, что Y не должен равняться (-7), поскольку на 0 делить нельзя, и X должен быть больше или равен модулю Y, поскольку нельзя извлекать корень из отрицательного числа.
PS: Если надо решение на Си++, то это сделать просто, основываясь на приведенной выше программе...
- 26.07.2016 22:26
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.