Вопрос по информатике:
1.Составить программу максимума из двух чисел.
2.Составить программу вычисления наибольшего из четырех чисел с использованием процедуры определения наибольшего из двух чисел.
- 02.05.2017 07:13
- Информатика
- remove_red_eye 16801
- thumb_up 19
Ответы и объяснения 1
1) program p1;
var a,b:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
if(a>=b) then writeln('максимальное число: ', a) else writeln('максимальное число: ', b);
end.
2)
program p1;
procedure MaxNumber(a,b: integer; var max: integer);
begin
if a>=b then max:=a else max:=b;
end;
var a,b,c,d,m:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
writeln('Введите 3-е число: ');read(c);
writeln('Введите 4-е число: ');read(d);
MaxNumber(a,b,m);
MaxNumber(m,c,m);
MaxNumber(m,d,m);
writeln('максимальное число: ',m);
end.
- 03.05.2017 07:32
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.