Вопрос по информатике:
Для выбора водящего в детской игре N человек становятся в круг,после чего произносится считалка.На первом слове считалки указывается на первого человека в кругу,на втором слове - на второго человека и т.д. После N-го человека снова идет первый человек (все люди в кругу пронумерованы числами от 1 до N,круг зацикливается,после человека с номером N идет человек с номер 1)
Всего в считалке M слов.Определите на какого человека придется последнее слово считалки.
Программа получает на вход два целых положительных числа.Первое число N-количество людей в кругу.Второе число M - количество слов в считалке.Оба числа не превосходит 10^9.
Программа должна вывести одно число от 1 до N - номер человека в кругу на которого придется последнее слово считалки
Ввод Вывод
10 5
15
- 26.10.2017 00:27
- Информатика
- remove_red_eye 13747
- thumb_up 20
Ответы и объяснения 1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 import java.io.*; public class Main { public static void main(String[] args) throws Exception { DataInputStream in = new DataInputStream(System.in); long n, m, result=0; n = Integer.parseInt(in.readLine()); m = Integer.parseInt(in.readLine()); if(mn){ m=m-n; result = m; if(result<0){ result *=-1; } } } System.out.println(result); } }
- 27.10.2017 19:35
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.