Вопрос по информатике:
Составьте программу для вычисления суммы ряда .S=2/3 *N + 2/3 * N^2 + 2/3 *N^n. с функцией или процедурой СРОЧНО
- 11.09.2017 12:11
- Информатика
- remove_red_eye 7083
- thumb_up 9
Ответы и объяснения 1
Program test;
function s(n,a:integer) : real;
var i,p:integer;
begin
p:=1;
if n>1 then begin
for i:=1 to n do p:=p*a;
s:=p;
end;
end;
function sum(n:integer) : real;
var i:integer;
sum1:real;
begin
for i:=1 to n do begin
sum1:=sum1+(2/3)*s(i,n);
end;
sum:=sum1;
end;
var
n:integer;
begin
write('Введите количество чисел ');
readln(n);
writeln(sum(n));
end.
- 12.09.2017 15:55
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.