Вопрос по информатике:
Даны натуральные числа n a1....an. составьте программу которая вычисляет сумму тех элементов последовательности а1...an которые кратны 3м
- 19.01.2018 17:25
- Информатика
- remove_red_eye 13811
- thumb_up 15
Ответы и объяснения 1
Const n=100;
var a: array [1..n] of integer;
s,i: integer;
begin
s:=0;
for i:=1 to n do
{ вывод массива на экран }
begin
a[i]:=Random(100);
write(a[i],' ');
if (i mod 10 =0) then writeln();
end;
{ подсчет суммы элементов, кратных 3 }
for i:=1 to n do
if (a[i] mod 3 =0) then s:=s+a[i];
writeln('сумма равна ',s);
end.
- 20.01.2018 06:55
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.