Вопрос по информатике:
Написать программу которая определяет является ли введённое с клавиатуры натуральное число N простым числом (N<32000)
- 09.12.2015 11:53
- Информатика
- remove_red_eye 2436
- thumb_up 14
Ответы и объяснения 1
Program test;
uses utils;
var
n,i,sum,time:longint;
flag:boolean;
begin
readln(n);
if n<2 then flag:=false;{Единица - не простое число}
if n=2 then flag:=true;{2 - простое}
if (n>2) and (n mod 2 0) then begin{ после двойки простые числа только нечетные}
for i:=1 to n do begin{проверяем что бы было только 2 делителя}
sum:=sum+1;
end;
if sum=2 then flag:=true;
end
else flag:=false;
if flag then writeln('Число простое') else writeln('Число НЕ простое');
time:=milliseconds;
writeln('Времени затрачено ',time:10,' ms.');
end.
Все проверки сделаны для сокращения времени работы программы.
- 01.01.1970 00:00
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.