Вопрос по информатике:
Нужно написать программу подсчитывающую количество чётных и не чётных цифр в числе
- 11.10.2017 19:23
- Информатика
- remove_red_eye 16158
- thumb_up 28
Ответы и объяснения 1
//PascalABC.Net 3.0, сборка 1053
var
n: longint;
d, n1, n2: integer;
begin
n1 := 0; n2 := 0;
Write('Введите натуральное число: ');Read(n);
repeat
d := n mod 10;
if odd(d) then Inc(n1) else Inc(n2);
n := n div 10
until n = 0;
Write('Нечетных ', n1, ', четных ', n2)
end.
Тестовое решение:
Введите натуральное число: 3534052
Нечетных 4, четных 3
- 12.10.2017 07:47
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.