Вопрос по информатике:
Задача: У вас есть доллары. Вы хотите обменять их на рубли. Есть информация стоимости купли-продажи в банках города. В городе N банков. Составьте программу, определяющую, какой банк выбрать, чтобы обменять доллары на рубли наиболее выгодно.
Язык программирования Паскаль ABC
- 19.08.2018 01:58
- Информатика
- remove_red_eye 6414
- thumb_up 50
Ответы и объяснения 1
Program p1;
const n=5;
var i:integer;
kurs: array[1..n] of real;
summa,r,bank: real;
begin
writeln('Введите сумму: ');
read(summa);
for i:=1 to n do begin
writeln('Введите курс в ',i,' банке: ');
read(kurs[i]);
end;
r:=0;
for i:=1 to n do begin
if (kurs[i]*summa)>r then
begin
r:=kurs[i]*summa;
bank:=i;
end;
end;
writeln('Выгодно в банке №: ',bank);
end.
- 20.08.2018 11:17
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.