Вопрос по информатике:
Ребят помогите
1.составить программу вычисления суммы нечётных чисел от 1 до 100
2.составить программу,которая находит суммуквадратов чисел от 1 до 100
- 06.09.2017 00:05
- Информатика
- remove_red_eye 2599
- thumb_up 47
Ответы и объяснения 1
Задание первое, решение на Pascal:
var
c, i, sum: integer;
begin
sum := 0;
for i := 1 to 100 do
begin
c := i mod 2;
if (c = 0) then sum := sum + i;
end;
writeln('Сумма нечётных чисел от 1 до 100 равна ', sum);
end.
Задание второе, решение на Pascal:
var
i, sum: integer;
begin
sum := 0;
for i := 1 to 100 do
begin
sum := sum + sqr(i);
end;
writeln('Сумма квадратов чисел от 1 до 100 равна ', sum);
end.
- 06.09.2017 23:01
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.