Вопрос по информатике:
Очень срочно помогите написать программу!
вот задача:
Заполнить массив из 12 элементов случайными числами в интервале [-12..12] и выполнить инверсию для каждой трети массива.
Пример:
Исходный массив:
4 -5 3 10 | -4 -6 8 -10 | 1 0 5 7
Результат:
10 3 -5 4 | -10 8 -6 -4 | 7 5 0 1
- 06.06.2018 10:51
- Информатика
- remove_red_eye 3727
- thumb_up 21
Ответы и объяснения 1
Var
a: array[1..12] of integer;
i: integer;
begin
randomize;
for i:=1 to 12 do
a[i]:=random(12+12+1)-12; //Заполнение массива
writeln('Исходный массив: ');
for i:=1 to 12 do
write(' ',a[i],' '); //Вывод исходного массива
writeln(); //Для перехода на следующую строку
writeln('Результат: ');
for i:=4 downto 1 do
write(' ',a[i],' ');
for i:=8 downto 5 do
write(' ',a[i],' ');
for i:=12 downto 9 do
write(' ',a[i],' '); //Обратный цикли для каждой трети
end.
- 07.06.2018 22:48
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.