Вопрос по информатике:
Пирожок в школьной столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a,b,n (0<=a<=1000, 0<=b<=99,1<=n<=1000) и должна вывести два числа: стоимость покупки в рублях и в копейках.
Пример
Ввод Вывод
10 20 30
15
2
----------------------
2 10 0
50
4
- 06.09.2018 06:45
- Информатика
- remove_red_eye 15071
- thumb_up 38
Ответы и объяснения 1
#include
#include
using namespace std;
void pie_price(int a, int b, int n)
{
assert((a >= 0) && (a <= 1000));
assert((b >= 0) && (b <= 99));
assert((n >= 1) && (n <= 1000));
double price = a * 1.0 + b / 100.0;
float res = price * n;
int kop = res * 100;
cout << "Rubles " << res << endl;
cout << "Kopeyks " << kop << endl;
}
int main()
{
int a, b, n;
cin >> a >> b >> n;
pie_price(a, b, n);
}
- 07.09.2018 14:32
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.