Вопрос по информатике:
Пожалуйста напишите мне данное задание от Program до End.
(Тема "Циклы"- Pascal ABC)
Написать программу, которая вычисляет сумму первых в членов ряда: 1,3,5,7...
Количество суммированных членов ряда задаётся во время работы программы.
Ниже приведен примерно рекомендуемый вид экрана во время работы программы.
Вычисление частичной суммы ряда:1,3,5,7...
Введите количество суммированных членов ряда ->1-5
Сумма первых 15 членов ряда равна 330.
- 23.07.2015 15:53
- Информатика
- remove_red_eye 10874
- thumb_up 14
Ответы и объяснения 1
Program zhn;
var
i,n,sum:integer;
begin
writeln('Вчисление суммы членов последовательности: 1,3,5,7...');
write('Введите количество членов для сложения:');
readln(n);
for i:=1 to n*2 do begin
if i mod 2 0 then sum:=sum+i; //Проверяем что бы число было нечетным
end;
writeln('Сумма ',n,' членов прогресии = ',sum);
end.
- 24.07.2015 21:15
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.