Вопрос по информатике:
1) Какие из описаний могут быть именами переменных
a) 2a
b) summa
c) a2
d) сумма
2) Какая команда служит для ввода значений переменных в Pascal? Приведите пример.
3) Найдите и исправьте ошибки в следующей программе:
program a;
var a, b, c: integer;
begin
writeln(‘введите значения переменных a и b’);
read(a, b);
writeln((a+b+c)/3);
end.
4) Напишите программу для решения одной из двух задач:
a) Найти площадь трапеции с основаниями а и b и высотой h.
b) Найти значение выражения:
5) Напишите программу для нахождения суммы цифр трехзначного числа.
- 24.03.2018 18:28
- Информатика
- remove_red_eye 3886
- thumb_up 17
Ответы и объяснения 1
1) Б и С
2) read(a) ввод в переменную с клавиатуры. a:=значение просто присваивание
3)
program a1;
var a, b, c: integer;
begin
writeln('введите значения переменных a и b');
read(a, b);
writeln((a+b+c)/3);
end.
Название программы и переменной были одинаковые. Так нельзя. Переименовал программу
4) б)
program znanija;
var a, b, h: integer;
begin
writeln('Введите a, b и h');
read(a, b, h);
writeln('Площадь трапеции ',(a+b)/2*h);
end.
5)
program znanija;
var a, b, i: integer;
begin
read(a);
for i:=1 to a do
begin
b:=b + a mod 10;
a:=a div 10;
end;
writeln(b);
end.
Работает не только для трёхзначных. Но и двух, трёх, четырёх и т.д.
- 25.03.2018 04:37
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.