Вопрос по информатике:
Вывести все значения элементов заданной числовой последовательности.
Входные данные: Выходные данные:
Во входном потоке в первой строке записано единственное целое число N (0 < N <= 100) - число элементов числовой последовательности;
Во второй строке перечислены вещественные значения элементов числовой последовательности (через пробел). Значения элементов по модулю не превышают 1000.
В выходной поток вывести значения элементов числовой последовательности в столбик с точностью три знака после запятой.
Пример входного файла (input.txt):
10
43.4 564.54 32.435 76.654 342.6456 76....
- 27.09.2018 15:39
- Информатика
- remove_red_eye 4645
- thumb_up 22
Ответы и объяснения 1
Var
a:array[1..1000] of extended;
i,n:longint;
begin
readln(n);
for i:=1 to n do read(a[i]);
writeln;
for i:=1 to n do writeln(a[i]:0:3);
end.
- 28.09.2018 09:08
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.