Вопрос по информатике:
1.составьте программу вычисления суммы цифр двузначного числа
2. составьте программу вычисления суммы цифр трёхзначного числа
- 22.05.2018 02:32
- Информатика
- remove_red_eye 11840
- thumb_up 25
Ответы и объяснения 1
Program znanija;
var a,s:integer;
begin
Read(a);
while a0 do
begin
s:= s + a mod 10;
a:= a div 10
end;
writeln(s);
end.
Работает для многозначных цифр не превышающих integer
- 23.05.2018 23:02
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.