Вопрос по информатике:
Передавая записку на уроке английского языка, друзья не хотят, чтобы кто-то прочел ее содержимое. Для этого текст шифруют простым методом: заменяют каждую букву на букву, расположенную в алфавите на расстоянии N символов от исходной. Считается, что алфавит циклически замкнут. Напишите программу-шифровальщик.
- 20.09.2017 03:19
- Информатика
- remove_red_eye 1589
- thumb_up 16
Ответы и объяснения 1
Const
N = 5;
EN = 'abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ';
RU = 'абвгдеёжзийклмнопрстуфхцчшщьыъэюяАБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЬЫЪЭЮЯ';
Var
S : String;
i : Byte;
Begin
Readln(S);
For i:=1 to Length(S) do
Begin
If Pos(S[i],EN)>0 then
If Pos(S[i],EN)+N<=Length(EN) then
S[i]:=EN[Pos(S[i],EN)+N] else S[i]:=EN[Pos(S[i],EN)+N-Length(EN)];
If Pos(S[i],RU)>0 then
If Pos(S[i],RU)+N<=Length(RU) then
S[i]:=RU[Pos(S[i],RU)+N] else S[i]:=RU[Pos(S[i],RU)+N-Length(RU)];
end;
Writeln(S);
end.
- 21.09.2017 08:03
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.