Вопрос по информатике:
Сумма 2 квадратов написать программу определяющую возможность представления заданного натурального числа n в виде суммы двух квадратов натуральных чисел
- 26.08.2015 03:22
- Информатика
- remove_red_eye 15367
- thumb_up 26
Ответы и объяснения 1
Вот программа , если мы хотим сложить 2 квадрата одного числа
program sqr;
var n,a: integer;
begin
write ('Введите число>>');
read (n);
a:= n*n+n*n;
writeln (a)
end.
Но если мы хотим выразить 1 число в виде суммы 2-х квадратов и проверить возможно ли это, то (боюсь ошибиться)
program sqr;
uses crt;
var n: integer; a,b:real;
begin
write ('Введите число>>');
read (n);
a:= sqrt(n);
if (a= sqrt(n)) and (a=(n*n)) then
begin
b:= sqrt(a);
if b= (a*a)+(a*a) then
writeln ('Можно');
if b (a*a)+(a*a) then
writeln ('Нельзя');
end;
if (a= sqrt(n)) and (an*n) then
writeln ('Нельзя')
end.
- 27.08.2015 03:39
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.