Вопрос по информатике:
Dev_c++
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.
- 20.05.2016 16:14
- Информатика
- remove_red_eye 2388
- thumb_up 40
Ответы и объяснения 1
#include
#include ;
using namespace std;
int main(int argc, char* argv[])
{
setlocale(LC_ALL, "Russian");
double x1,x2,y1,y2,distance;
cout <<"Введите координату x1:";
cin>>x1;
cout <<"Введите координату y1:";
cin>>y1;
cout <<"Введите координату x2:";
cin>>x2;
cout <<"Введите координату y2:";
cin>>y2;
distance=sqrt(pow((x2-x1),2)+pow((y2-y1),2)); // формула для вычисления расстояния
cout<<"Расстояние между двумя точками:"<
}
- 21.05.2016 21:37
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.