Вопрос по информатике:
Помогите пожалуйста!!! Составить программы Pasсal
1) Даны величины двух углов треугольника в градусах.
Составьте программу, которая определяет, существует ли такой треугольник. Если да, то будет ли он остроугольным, прямоугольным или тупоугольным.
2)На плоскости XOY заданы своими координатами три не совпадающие точки А(X1, Y1),
B(X2, Y2) , и C(X3 , Y3).
Составить программу, которая определяет, где расположена точка C ;
выше, ниже или на отрезке АВ.
- 22.01.2018 03:22
- Информатика
- remove_red_eye 13780
- thumb_up 20
Ответы и объяснения 1
Первая задача
program firstProgram
var ug1, ug2: real;
begin
write("Введите первый угол: ");
read(ug1);
write("Введите второй угол: ");
read(ug2);
if ((ug1 + ug2) < 180)
begin
if ((ug1 > 90) or (ug2 > 90)) write("Треугольник тупоугольный");
else if ((ug1 = 90) or (ug2 = 90)) write("Треугольник прямоугольный");
else write("Треугольник остроугольный");
end
end
- 23.01.2018 20:36
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.