Вопрос по информатике:
Написать программу на любом из яп: pascal,c#,php
Боря Лейкин на время каникул устроился работать помощником почтальона. Сегодня ему необходимо доставить телеграмму в квартиру n девятиэтажного дома, в
котором несколько подъездов, а на каждом этаже подъезда по четыре квартиры Требуется написать программу, которая по номеру квартиры n выведет номер подъезда и этаж на котором находится эта квартира.
- 27.06.2015 07:09
- Информатика
- remove_red_eye 10009
- thumb_up 5
Ответы и объяснения 1
// PascalABC.Net
const
e=9; // этажность дома
k=4; // количество квартир на этаже
var
n,pn,c,en:integer;
begin
Write('Укажите номер квартиры: '); Read(n);
c:=e*k; // количество квартир в подъезде
pn:=(n-1) div c + 1; // номер подъезда
en:=(n-(pn-1)*c-1) div 4 + 1; // номер квартиры
writeln('Подъезд ',pn,', этаж ',en)
end.
Тестовое решение:
Укажите номер квартиры: 54
Подъезд 2, этаж 5
- 28.06.2015 23:39
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.