Вопрос по информатике:
Пусть дано некоторое целое число. Требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное. И если это число положительное, уменьшает его в 2 раза, в противном случае возводит его в квадрат.
- 21.06.2018 17:37
- Информатика
- remove_red_eye 9671
- thumb_up 42
Ответы и объяснения 1
Program a2;
var a,b:integer;
begin
write('Введите целое числo');
readln(a);
if a > 0 then begin
b:=a div 2;
end
else
begin b:=a*a;
end;
write ('b',b);
end.
- 22.06.2018 21:49
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.