Вопрос по информатике:
Напишите программу в паскаль abc, которая позволяют записать логические выражения, которые имеют значение «Истина» когда:
а) каждое из чисел A и B больше 100;
б) только одно из чисел A и B четное;
в) хотя бы одно из чисел A и B положительное.
- 07.04.2018 20:16
- Информатика
- remove_red_eye 10353
- thumb_up 34
Ответы и объяснения 1
Var a,b:real;
l,f,j:boolean;
begin
f:=false;
read (a,b);
if (a > 100) and (b > 100) then l:=true else l:=false;
if ((a mod 2)=0) then f:=true;
if ((b mod 2)=0) then f:=true;
if ((a mod 2)=0) and ((b mod 2)=0) then f:=false
if a > 0 or b > 0 then j:=true else j:=false;
writeln ("а) ",l);
writeln ("б) ",f);
writeln ("в) ",j);
end.
- 08.04.2018 21:17
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.