Вопрос по информатике:
Требуется поменять местами первый элемент массива с максимальным.
ВХОДНЫЕ ДАННЫЕ
В первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. Во второй строке задаются N чисел — элементы массива (целые числа, не превосходящие по модулю 1000).
ВЫХОДНЫЕ ДАННЫЕ
Вывести получившийся массив. Если максимальных элементов несколько, требуется поменять первый из них.
- 01.07.2016 08:30
- Информатика
- remove_red_eye 14223
- thumb_up 31
Ответы и объяснения 1
Var a:array[1..1000] of integer;
n,i,im,max:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
writeln;
max:=a[1];im:=1;
for i:=1 to n do
if a[i]>max then
begin
max:=a[i];
im:=i;
end;
a[1]:=a[1]+a[im];
a[im]:=a[1]-a[im];
a[1]:=a[1]-a[im];
for i:=1 to n do
write(a[i],' ');
end.
- 02.07.2016 07:28
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.