Вопрос по информатике:
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба
соседних элемента меньше данного.
Входные данные
Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей.
Примеры
Входные данные
5
1 2 3 4 5
Выходные данные
0
Входные данные
5
1 5 1 5 1
Выходные данные
2
- 03.10.2017 05:07
- Информатика
- remove_red_eye 19818
- thumb_up 21
Ответы и объяснения 1
Var
A:array[1..100]of integer;
N,S:byte;
Begin
Read(N);
For N:= 1 to N do
Read(A[N]);
For N:= 2 to N-1 do
if (A[N]>A[N-1])and(A[N]>A[N+1]) then S:=S+1;
Write(S)
End.
- 04.10.2017 12:57
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.