Вопрос по информатике:
Помогите пожалуйста! Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения
- 19.08.2015 14:50
- Информатика
- remove_red_eye 4341
- thumb_up 43
Ответы и объяснения 1
Const
N = 7;
Var
A:array[1..N]of integer;
i:integer;
S,Sn,P,Pn:real;
Begin
S:=0;
Sn:=0;
P:=1;
Pn:=1;
For i:= 1 to N do
Begin
A[i]:=random(7)+1;
Write(A[i],' ');
if A[i] mod 2 = 0 then
Begin
S:=S+A[i];
P:=P*A[i];
End
else
Begin
Sn:=Sn+A[i];
Pn:=Pn*A[i];
End
End;
WriteLn;
WriteLn('Сумма чётных элементов =',S);
WriteLn('Произведение чётных элементов =',P);
WriteLn('Сумма НЕчётных элементов =',Sn);
WriteLn('Произведение НЕчётных элементов =',Pn);
End.
- 20.08.2015 12:53
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.