Вопрос по информатике:
Дан массив из 20 действительных чисел. Напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты. Желательно подробную программу, буду всем благодарна)
- 09.08.2018 16:47
- Информатика
- remove_red_eye 9873
- thumb_up 48
Ответы и объяснения 1
Var A:array[1..20]of real;
B,C:real;
i:byte;
Begin
WriteLn('Введи элементы массива через пробел');
For i:= 1 to 20 do
Read(A[i]);
For i:= 1 to 20 do
if A[i]>0 then B:=B+A[i]
else C:=C+A[i];
WriteLn('Сумма положительных элементов = ',B);
WriteLn('Сумма отрицательных = ',C)
End.
- 01.01.1970 00:00
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.